Netflix on Apple TV 4k issues

Hi. Need some advice.

I have my Apple TV 4K connected to Denon 8500 and then to JVC NX5.

Apple TV video settings is 4K SDR with Dynamic Range and Frame matching turn on.

With the above, Netflix UltraHD movies cannot be displayed. Blank Screen. With dynamic range off, Netflix UltraHD movies are shown in 4K SDR.

Apple TV set to 4K HDR and dynamic range on, Netflix UltraHD movies cannot be seen too. With Dynamic Range off, shows are in 4K HDR.

Seems like Dynamic Range Matching does not work for Netflix.

Anyone face the same issues?

P.S. Apple TV+ works fines.

Thanks

Happen only recently? any firmware update on the Apple TV of late?

I just bought it. So update it to tvOS14.3

maybe the HDMI cable uesd cant handle the bandwidth?

Thanks. I dont think so. It happens only to Netflix shows that have HDR or UltraHD tag on it. Apple TV+ is good too. I notice 2 things today

  1. I moved the Apple TV to my living room setup which is a Denon 4500 with Samsung QLED TV. Same thing. Netflix shows with HDR and UltraHD is shown in SDR if Apple TV video settings is 4K SDR with Dynamic Range and Frame rate matching on.

  2. I notice now Netflix show some movies with Dolby Vision tag. Do not understand why as both the JVC NX3 and Samsung TV do not support DV. If i played these shows, it is output as 4K HDR(i.e. dynamic matching works for this)

I used to own Apple TV 4K and paired with JVC NX7 projector but I’ve since sold both items. Yes, you are right, no projector support DV at this point so Netflix shouldn’t display DV tag but HDR tag. It’s odd. I do not recall seeing those. Matching frame rate and dynamic content should always be enabled to ensure the display trigger the correct EDID to playback the native 4K source, in this case from the Netflix on your Apple TV 4K.

Search Reddit group to see if any user also encounter same issue. This is likely caused by Apple firmware. U may want to try beta firmware and see if it solves your woes.

When you set both dynamic range and frame rate match to on, you just need to set the display to 4k SDR 24fps. It will automatically match content according to source material

UHD should be 4k SDR, the source material with DV/HDR will inject the metadata so your jvc will kick in in HDR mode

Either it’s the hdmi cable issue or the firmware. Before I parted ways with the ATV4K, I was on the latest beta firmware. No such issues with Atmos or DV/HDR with Netflix

Maybe don’t use RGB, switch it to YCbCr and see if that helps with bandwidth

Thanks.

I guess its most likely with the firmware, prob Netflix app or TVOS. It works for DV movies, though totally no idea why it detected it.

Am using YCbCr.

I have tried connecting Apple TV directly to another TV. Same result. Only Netflix HDR shows cannot matched.

Hope there will be a fix soon…:grinning:

Latest firmware should be 14.4, working fine for me.

I just check, still 14.3.

Is 14.4 developer beta?

It is working for you on 14.3?

Thanks

You may be right that 14.4 is a beta. It also works well for 14.3 before I update to 14.4. I am just using a 4k TV not projector. Is it due to HDMI cable?

The best bet is to update to 14.4 beta and see if everything work. No harm right

Only happens for Netflix HDR shows, the other apps like TV+ are ok. Thus i guess is not with the cable.

I have tried it on all my 3 setups each with different cables, namely
ATV - AVC8500 - NX5
ATV - AVR4500 - Samsung 65Q7
ATV - Samsung 55Q7

All same results. Can get HDR for shows Netflix tagged as DV but not for shows tagged HDR.

My ATV settings are
Video : 4K SDR 60
Dynamic Range Matching : On
Frame Range Matching : On

Guess will wait next release and see how. No guts to try beta…:grin::grin:

I was trying to recall what I have done. There are 2 updates for beta 14.4 which I have done the 2nd one last night so all the while I have been running 14.4. Can’t remember about the display issues but I do remember 14.3 couldn’t play Atmos.

I have been downloading beta firmware for a while now. Most of the time, they run well and if there are some issues, usually Apple is quite prompt to fix it.

I am also having the same setting as you. I believe you are right that it is a firmware issue.

1 Like

Ya the new TV OS has tons of issues. First was Atmos audio not being able to pass through. Then I took the risk and went for the beta updates.

I understand the risk with beta updates, but after desray confirmed all good to go, I proceeded to use beta firmware. Never had any problems since

No issues. So I’ve been on the beta version for some months, then once I got the Xbox series X dialed in, I gave the ATV4K away

I read from the net. I guess just need to register a beta account apple id and login from ATV4.

To revert back to commercial IOS, just login using my apple id

Is that correct?

It’s actually more idiot proof. Just go to settings and enable Beta and then invoke the software update. That’s it.

The problem here is once the beta goes bad, you can’t revert to the official firmware.

To revert, is it not disable the update and wait for the next official firmware update.?..during this period, guess got to take it.:grinning:

Yes. U can do that. Make sure u disable the beta option once the official firmware is pushed down. Just remember, once u update to the beta firmware, there is no returning back. Good or bad, u just need to live with it until official firmware pushed down or the next avail beta firmware is made avail (usually around 2 weeks update cycle).

On my ATV4K, which is connected to my BenQ W2700 via a Vertex2, for Netflix, it shows either the Dolby Vision Logo or “Ultra HD 4K”. There is no HDR. Ultra HD 4K is SDR. I’m therefore surprised you see the Dolby Vision Logo, when neither of your displays is DV capable.

If setting the ATV4K user interface to 4K HDR works for you, suggest that you set matching dynamic range to off. That way everything will be in HDR and you will get HDR for your HDR movies. Apple TV will convert “UltraHD 4K” to HDR. If that is acceptable to you, then you are done.


Copyright © 2020. AV Discourse. All Rights Reserved.
Powered by Discourse App.